Pomm 2.0.1 is out, 2.1.0 is on track.

Posted 3 years ago.

We are happy to announce Pomm 2.0.1 is now available. This is a maintenance release. There are very few commits between this tag and the 2.0.0. This is a very good news for us. As we have more and more feedbacks from Pomm users, with between 700 and 800 downloads per month, it means Pomm is very stable.

Coming with that news, the Pomm 2.0 branch has been forked from master, which means 2.1 developments are on the way. What’s on the menu :

PHP 5.4 support drop

Many users asked why Pomm does support a deprecated version of PHP. Pomm 2.0 is tested from PHP 5.4 to PHP 7.0. Since it does not prevent to take advantage of new PHP goodnesses, it is actually a feature to have a lib working and tested on a wide range of PHP versions even though some are deprecated already. Looking at the stats, in 2014, 30% of packagist users were using PHP 5.4. This part is now reduced to 15% with 73% of the users having PHP >= 5.5. Even though Pomm 2.0 will always be compatible with PHP 5.4, it is time to move on, Pomm 2.1 will not support it anymore.

Add your feature here

There are a lot of ideas already like the use of the Judy extension for the client holder and identity mapper, the support of the COPY protocol to import data etc. The inspector client provided by Pomm is useful but it is a bit too simple in Pomm 2.0. A completely revamped Inspector will be presented. This can be interesting in migration processes or database discovery. Please fell free to share what you would like to see in Pomm 2.1.

Enjoy.